Menu
Авторизация:
Зарегистрироваться.
проблема при апгрейде.
Пользователь: def
Дата: 7-апреля-2006 11:15 am
Просмотров: 51159
Оценка: 1    Оценить [
|
]

 

При переходе с версии 6.8.7 на 6.8.8 произошла ошибка. К сожалению я не сохранил вывод  ошибки, но это выглядело как:

could'n  load file /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi/APR к сожалению не помню имени файла но оно заканчивалось на "*.so". Постараюсь завтра выложить полное описание проблемы. Да еще так указывалась какая-то неизвестная переменная.

 

Благодарю за ответы... 

--- (Отредактировано 7-April-2006 11:15 am [GMT+0300]Написал(а)def) ---

 

--- (Отредактировано 7-April-2006 11:15 am [GMT+0300]Написал(а)def) ---

Re: проблема при апгрейде.
Пользователь: Admin
Дата: 7-апреля-2006 2:22 pm
Просмотров: 5876
Оценка: 2    Оценить [
|
]

Я попробовал выполнит апгрейд на одном из серверов - всё прошло без ошибок.

Но обнаружено другое - есть опечатки в "WebGUI/lib/WebGUI/Operation/FormHelpers.pm"

Это никак не связано с ошибками, при апгрейде, но, если не исправить - будет мешать при работе. 

Необходимо изменить вледующие стороки:

<title>'.$title.'
<meta http-equiv="Content-Type"
content="text/html;charset=UTF-8" />

на:

<title>'.$title.'</title>
<meta http-equiv="Content-Type" content="text/html;
charset=UTF-8" />

а также

Line 85:

WebGUI::Style::setScript($session{config}{extrasURL}."/tinymce/jscripts/tiny_mce/tiny_mce_popup.js",{type=>"text/javascript"});

на:

WebGUI::Style::setScript($session{config}{extrasURL}."/tinymce2/jscripts/tiny_mce/tiny_mce_popup.js",{type=>"text/javascript"});

и ещё

Line 162:

return _outputWrapper($image->getTitle,'<div
align="center"><img
src="'.$session{config}{extrasURL}.'/tinymce/images/icon.gif"
border="0" alt="Image Manager"></div>');
}

возможно на:

return _outputWrapper($image->getTitle,'<div
align="center"><img
src="'.$session{config}{extrasURL}.'/tinymce2/images/icon.gif"
border="0" alt="Image Manager"></div>');
}

Но папка  tinymce2/images/ - всё-равно не существует. Я, просто, скопировал её из предыдущих версий.

 


 

Пожалуйста, все вопросы и пожелания оставляйте на форуме, а не направляйте прямиком мне на E-mail

--- (Отредактировано 7-April-2006 2:22 pm [GMT+0300]Написал(а)Admin) ---

Re: проблема при апгрейде.
Пользователь: def
Дата: 8-апреля-2006 0:28 am
Просмотров: 5991
Оценка: -2    Оценить [
|
]

выкладываю ошибку:

Can't load '/usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi/auto/APR/APR.so' for module APR: /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi/auto/APR/APR.so: undefined symbol: apr_bucket_shared_split at /usr/lib64/perl5/5.8.5/x86_64-linux-thread-multi/DynaLoader.pm line 230.
 at /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi/APR/Table.pm line 23
Compilation failed in require at /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi/APR/Table.pm line 23.
BEGIN failed--compilation aborted at /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi/APR/Table.pm line 23.
Compilation failed in require at /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi/Apache2/Cookie.pm line 2.
BEGIN failed--compilation aborted at /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi/Apache2/Cookie.pm line 2.
Compilation failed in require at ../../lib/WebGUI/HTTP.pm line 19.
BEGIN failed--compilation aborted at ../../lib/WebGUI/HTTP.pm line 19.
Compilation failed in require at ../../lib/WebGUI/Asset/Template.pm line 20.
BEGIN failed--compilation aborted at ../../lib/WebGUI/Asset/Template.pm line 20.
Compilation failed in require at ../../lib/WebGUI/Form.pm line 21.
BEGIN failed--compilation aborted at ../../lib/WebGUI/Form.pm line 21.
Compilation failed in require at ../../lib/WebGUI/HTMLForm.pm line 20.
BEGIN failed--compilation aborted at ../../lib/WebGUI/HTMLForm.pm line 20.
Compilation failed in require at ../../lib/WebGUI/Auth.pm line 25.
BEGIN failed--compilation aborted at ../../lib/WebGUI/Auth.pm line 25.
Compilation failed in require at ../../lib/WebGUI/Grouping.pm line 18.
BEGIN failed--compilation aborted at ../../lib/WebGUI/Grouping.pm line 18.
Compilation failed in require at ../../lib/WebGUI/AssetLineage.pm line 19.
BEGIN failed--compilation aborted at ../../lib/WebGUI/AssetLineage.pm line 19.
Compilation failed in require at ../../lib/WebGUI/Asset.pm line 20.
BEGIN failed--compilation aborted at ../../lib/WebGUI/Asset.pm line 20.
Compilation failed in require at upgrade_6.8.7-6.8.8.pl line 14.
BEGIN failed--compilation aborted at upgrade_6.8.7-6.8.8.pl line 14.
        Processing upgrade executable failed!

The upgrade process failed and has stopped so you can either restore
from backup, or attempt to fix the problem and continue.
 

--- (Отредактировано 8-April-2006 12:28 am [GMT+0300]Написал(а)Visitor) ---

Re: проблема при апгрейде.
Пользователь: Admin
Дата: 8-апреля-2006 2:46 am
Просмотров: 5928
Оценка: 0    Оценить [
|
]

 

Похоже, что криво сел модуль libapreq2. Удивительно, как оно до этого работало... Ведь начиная с версии 6.8.0 - он обязательный.

Попробуйте его сначала удалить, а потом пересобрать заново с ключами:

./configure --with-apache2-apxs=/usr/local/apache2/bin/apxs --enable-perl-glue --with-perl=/usr/bin/perl

(проверьте, совпадают ли у Вас пути к apache2 и perl с моими)

После чего остановите и заново запустите apache.

Потом восстановите из бекапа базу, верните назад копию папки www/uploads, ту, что была перед апгрейдом (если сохранилась) и попробуйте заново.

Да, и Перл лучше бы 5.8.7, а не 5.8.5. (Последний 5.8.8 пока не пробовал...)

 


 

Пожалуйста, все вопросы и пожелания оставляйте на форуме, а не направляйте прямиком мне на E-mail

--- (Отредактировано 8-April-2006 2:46 am [GMT+0300]Написал(а)Admin) ---

 

--- (Отредактировано 8-April-2006 2:49 am [GMT+0300]Написал(а)Admin) ---

Re: проблема при апгрейде.
Пользователь: def
Дата: 8-апреля-2006 8:38 am
Просмотров: 5948
Оценка: 1    Оценить [
|
]

Спасибо! С libapreq проблема такая: версия 2.06-dev встает и работает нормально!, а вот с версией 2.07 (ну с последней доступной версией) ничего не получается - даже WebGUI не запускается. Вы какую версию советуете так ставить? С первой все работает нормально (имею ввиду ВэбГУИ), а вот 2.07 даже в таком виде не ставится. Вчера я действительно пробовал пересобрать весрию 2.07, но что-то система не пошла..., кстати собирал все так как Вы и советовали на форуме plainblack. Что делать? P.S. На резервном сервере (точная копия первого) все проапгрейдилось нормально. --- (Отредактировано 8-April-2006 8:38 am [GMT+0300]Написал(а)Visitor) ---

Re: проблема при апгрейде.
Пользователь: Admin
Дата: 8-апреля-2006 2:46 pm
Просмотров: 5780
Оценка: 2    Оценить [
|
]

У меня была версия 2.06-dev, потом я поставил 2.07 - с обеими работает.

Как проходит комманда "make test"?

Если жалуется, то на что? Сложно сказать удалённо. Может каких-то библиотек не находит... Проверьте пути. Иногда приходится добавлять симлинки с файлов в /usr/local на /usr

Может надо добавить пути в ld.so.conf

В любом случае, если не удасться побороть 2.07 - работайте с 2.06-dev ...

 


 

Пожалуйста, все вопросы и пожелания оставляйте на форуме, а не направляйте прямиком мне на E-mail

--- (Отредактировано 8-April-2006 2:46 pm [GMT+0300]Написал(а)Admin) ---

Re: проблема при апгрейде.
Пользователь: def
Дата: 8-апреля-2006 6:01 pm
Просмотров: 5854
Оценка: 0    Оценить [
|
]

make test выдал

Write out database with 1 new entries
Data Base Updated
[   info] linked ca-bundle.crl to 9d0c6ffe.r0
[  debug] generating c-modules/apache_httpd_test.h
[  error] configure() has failed:
Use of uninitialized value in scalar chomp at /usr/lib64/perl5/site_perl/5.8.5/x86_64-linux-thread-multi/Apache/TestConfigC.pm line 414.

[warning] forcing Apache::TestConfig object save
[  debug] generating conf/apache_test_config.pm
[  debug] saving config data to apache_test_config.pm
[warning] run 't/TEST -clean' to clean up before continuing
make[1]: *** [run_tests] Ошибка 1
 

--- (Отредактировано 8-April-2006 6:01 pm [GMT+0300]Написал(а)Visitor) ---

Re: проблема при апгрейде.
Пользователь: def
Дата: 9-апреля-2006 11:56 am
Просмотров: 5967
Оценка: 5    Оценить [
|
]

Пересобоал перл с флагом -fPIC - все равно не помогает... --- (Отредактировано 9-April-2006 11:56 am [GMT+0300]Написал(а)Visitor) ---

Re: проблема при апгрейде.
Пользователь: def
Дата: 10-апреля-2006 12:10 pm
Просмотров: 8913
Оценка: -5    Оценить [
|
]

ошибка была найдена! Проблема была в mod_ssl. Почему-то libapreq не подружился с ним. Сейчас все работает нормально. Дело в том, что резервный сервер послабее боевого и он сконфигурирован без ssl. А "боевой" - пусть теперь немного поживет без ssl пока не найдем варианты их совместного "проживания". Спасибо. --- (Отредактировано 10-April-2006 12:10 pm [GMT+0300]Написал(а)Visitor) ---

© 2004-2019 WebGUI на русском. | Powered by WebGUI
& use Foundation framework | Расположен на WebGUI hosting