WebGUI на русском

WebGUI на русском
Вот поставил но фейс запускается через раз

Menu
Авторизация:
Зарегистрироваться.
Вот поставил но фейс запускается через раз
Пользователь: Ivan
Дата: 30-марта-2006 9:56 pm
Просмотров: 37615
Оценка: 2    Оценить [
|
]
preload ***.pl пришлось закоменить ибо не пускается.

Все ето добро робит тут:
http://www.russiantarget.com/

Что делать нинаю :(
Re: Вот поставил но фейс запускается через раз
Пользователь: Admin
Дата: 30-марта-2006 9:56 pm
Просмотров: 5632
Оценка: -2    Оценить [
|
]

С первого взгляда определить сложно... Во всяком случае mod_perl работает.
(env.MOD_PERL = mod_perl/1.29)

Если он не стартует с preload.perl, то, видимо установлены не все перловые модули из тех, к которым он обращается или из тех, к которым обращаются те, к которым он обращается Tongue out

Попробуйте "пройтись" по всему списку, который загружает preload.perl с самого начала:

use CGI (); CGI->compile(':all');
use CGI::Carp ();
use CGI::Util ();
use File::Copy ();
use File::Path ();
use FileHandle ();
use POSIX ();
use URI::Escape ();
use HTTP::Request ();
use HTTP::Headers ();
use Digest::MD5 ();
use DBI ();
use HTML::Parser ();
use HTML::TagFilter ();
use HTML::Template (); # версия не ниже 2.7
use Parse::PlainConfig ();
use Net::SMTP ();
use Log::Log4perl ();
use Tie::IxHash ();
use Tie::CPHash ();
use Time::HiRes ();
use Date::Manip ();
use Image::Magick ();
use Storable;
use XML::Simple ();

Попробуйте запустить из коммандной строки на сервере testEnvironment.pl - что он скажет?

Какие записи об о

Re: Вот поставил но фейс запускается через раз
Пользователь: Ivan
Дата: 30-марта-2006 9:56 pm
Просмотров: 5296
Оценка: 1    Оценить [
|
]
Operating System:                            Linuxish
WebGUI Root:                                 ..
Perl Interpreter:                            OK
Checking for module LWP:                     OK
Checking for module HTTP::Request:           OK
Checking for module HTTP::Headers:           OK
Checking for module Digest::MD5:             OK
Checking for module DBI:                     OK
Checking for module DBD::mysql:              OK
Checking for module HTML::Parser:            OK
Checking for module Archive::Tar:            OK
Checking for module IO::Zlib:                OK
Checking for module Compress::Zlib:          OK
Checking for module Net::SMTP:               OK
Checking for module Cache::Cache:            OK
Checking for module Tie::IxHash:             OK
Checking for module Tie::CPHash:             OK
Checking for module XML::Simple:             OK
Checking for module SOAP::Lite:              OK
Checking for module Time::HiRes:             OK
/usr/libexec/ld-elf.so.1: /usr/local/lib/libMagick.so.9: Undefined symbol "pthread_equal"


perl preload.perl
/usr/libexec/ld-elf.so.1: /usr/local/lib/libMagick.so.9: Undefined symbol "pthread_equal"


Все переставил тока на libMagick ругается. нужно ее переставлять.
Завтра переставлю посмотрю на  результю
Re: Вот поставил но фейс запускается через раз
Пользователь: Admin
Дата: 30-марта-2006 9:56 pm
Просмотров: 5241
Оценка: 2    Оценить [
|
]

Только не забудьте после всех манипуляций перезапустить Apache и очистить ке

Re: Вот поставил но фейс запускается через раз
Пользователь: Ivan
Дата: 30-марта-2006 9:56 pm
Просмотров: 5233
Оценка: -1    Оценить [
|
]
perl testEnvironment.pl

WebGUI is checking your system environment:

Operating System:                            Linuxish
WebGUI Root:                                 ..
Perl Interpreter:                            OK
Checking for module LWP:                     OK
Checking for module HTTP::Request:           OK
Checking for module HTTP::Headers:           OK
Checking for module Digest::MD5:             OK
Checking for module DBI:                     OK
Checking for module DBD::mysql:              OK
Checking for module HTML::Parser:            OK
Checking for module Archive::Tar:            OK
Checking for module IO::Zlib:                OK
Checking for module Compress::Zlib:          OK
Checking for module Net::SMTP:               OK
Checking for module Cache::Cache:            OK
Checking for module Tie::IxHash:             OK
Checking for module Tie::CPHash:             OK
Checking for module XML::Simple:             OK
Checking for module SOAP::Lite:              OK
Checking for module Time::HiRes:             OK
Checking for module Image::Magick:           OK
Checking for module Log::Log4perl:           OK
Checking for module Net::LDAP:               OK
Checking for module Date::Manip:             OK
Checking for module HTML::Highlight:         OK
Checking for module HTML::TagFilter:         OK
Checking for module HTML::Template:          OK
Checking for module Parse::PlainConfig:      OK
Checking for module XML::RSSLite:            OK
Checking for module DBIx::FullTextSearch:    OK
WebGUI modules:                              Not Found. Perhaps you're running t
his script from the wrong place.

Вот вроде все модули поставил, теперь она сама по себе робить не хочет.
Сеня переставлю WebGUI ато мож я уже там чета угробил.
Re: Вот поставил но фейс запускается через раз
Пользователь: Admin
Дата: 30-марта-2006 9:56 pm
Просмотров: 5299
Оценка: -1    Оценить [
|
]

Проверьте правильность путей к сайту и WebGUI и конфигурационному файлу в файлах index.pl, preload.perl, httpd.conf www.russiantarget.com.conf.

Он почему-то ищет модули WebGUI в общих перловых библиотеках и не может их найти по тому пути, где они лежат. У меня нечто подобное было, когда я экспериментировал со suidperl в версии Perl 5.8.7...

Кстати, вышла версия 6.7.7. Исправлено много багов.


Пожалуйста, все вопросы и пожелания оставляйте на форуме, а не направляйте прямиком мне на E-mail

--- (Отредактировано в 18-Октября-2005 4:54 pm от Admin) --- --- (Отредактировано в 18-Октября-2005 5:08 pm от Admin) --- --- (Отредактировано в 18-Октября-2005 5:11 pm от Admin) ---
Re: Вот поставил но фейс запускается через раз
Пользователь: Ivan
Дата: 30-марта-2006 9:56 pm
Просмотров: 8383
Оценка: -2    Оценить [
|
]
Starting apache.
Subroutine WebGUI::Attachment::O_CREAT redefined at /usr/local/lib/perl5/5.8.7/Exporter.pm line 65.
at /usr/local/lib/perl5/5.8.7/mach/POSIX.pm line 19
Subroutine WebGUI::Attachment::O_EXCL redefined at /usr/local/lib/perl5/5.8.7/Exporter.pm line 65.
at /usr/local/lib/perl5/5.8.7/mach/POSIX.pm line 19
Subroutine WebGUI::Attachment::O_RDWR redefined at /usr/local/lib/perl5/5.8.7/Exporter.pm line 65.
at /usr/local/lib/perl5/5.8.7/mach/POSIX.pm line 19

Starting WebGUI 6.2.11
       Loading www.russiantarget.com.conf
WebGUI Started!



Выдает какие то ошибки но пускается и работает.
Поставил версию 6.2.11 остальные отказались нормально работатью

© 2004-2019 WebGUI на русском. | Powered by WebGUI
& use Foundation framework | Расположен на WebGUI hosting